Service Issues Due to Azure Outage

Incident Report for Grow (EU)

Resolved

The issue affecting our AI services has been resolved, and systems are operating normally.
Posted Jan 27, 2026 - 17:39 GMT

Monitoring

We have identified the issue and actively working on resolving it.
Posted Jan 27, 2026 - 17:30 GMT

Update

We are continuing to work on a fix for this issue.
Posted Jan 27, 2026 - 15:35 GMT

Identified

We are currently investigating an issue affecting the availability of our AI services. Some users may experience errors, slower performance, or difficulty performing actions related to AI.

We will provide an update as more information becomes available.
Posted Jan 27, 2026 - 14:46 GMT
This incident affected: Grow (EU).